jwildfire.org

The official JWildfire forum
It is currently Thu May 06, 2021 2:09 am

All times are UTC+01:00




Post new topic Reply to topic  [3 posts ] 
Author Message
PostPosted:Sun Mar 28, 2021 9:23 pm 
Offline

Joined:Sun Aug 09, 2020 7:16 am
Posts:2
Just tried to open JWildfire in Steam yesterday and it wouldn't launch. I got a small dialogue box titled "JWildfire.exe" which said "Failed to launch JVM" and an "OK" button. When I click on that, the launcher closes.

I've tried restarting both Windows and Steam, and made sure everything is up to date. But the problem persists. (Alas, I haven't used JWildfire in a few months, so I can't tell exactly when this problem started, but my latest saved file is January 2, 2021.)

I have (of course) downloaded the non-Steam version of 6.22, and that runs without any trouble at all. So this problem isn't urgent for me, but I figured you'd want to know.

My JWildfire.cfg is as follows:
The current JWildfire.cfg is as follows:

[Application]
app.name=JWildfire
app.version=6.22
app.runtime=$ROOTDIR\runtime
app.identifier=org.jwildfire.swing
app.classpath=$ROOTDIR\app\j-wildfire.jar
app.mainjar=$ROOTDIR\app\j-wildfire.jar
app.mainclass=org.jwildfire.swing.JWildfire

[JavaOptions]
-splash:app/splash.png
-Xmx8G

[ArgOptions]


Here is info on my PC:

Processor: AMD Ryzen 7 1700 Eight-Core Processor, 3.00 GHz
Video Card: NVIDIA GeForce GTX 1080 (which has 8 GB video ram and has run OptiX renders beautifully)
Installed RAM: 16.0 GB
System type: 64-bit operating system, x64-based processor
Operating System: Windows 10 Pro, Version 20H2, Build 19042.870


Last edited by SilkFractalSpinner on Mon Mar 29, 2021 5:28 am, edited 1 time in total.

Top
   
PostPosted:Mon Mar 29, 2021 12:09 am 
Offline
Site Admin
User avatar

Joined:Wed May 15, 2013 10:28 pm
Posts:1538
did you change the JWildfire.cfg, for example to change the memory settings? When they are too high, the JVM can't start.


Cheers!

Andreas


Top
   
PostPosted:Mon Mar 29, 2021 5:32 am 
Offline

Joined:Sun Aug 09, 2020 7:16 am
Posts:2
Quote:
did you change the JWildfire.cfg, for example to change the memory settings? When they are too high, the JVM can't start.
As it happens, I hadn't tried to use the Steam version of JWildfire since early January, and so it had updated and there is now a cfg with (so far as I know) just the default settings, including -Xmx8G which is lower than my default for the previous version I used (6.20, where I had it set to -Xmx14G).

I've updated my original post to include the text of the entire current JWildfire.cfg in light blue.

Many thanks for helping me with this!

— Sage Ealy-Silk


Top
   
Display posts from previous: Sort by 
Post new topic Reply to topic  [3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Theme Created by HOLLYSMOKE
Theme updated to phpBB 3.1.6 by KamijouTouma
Theme Version is 3.1.6-ss2