jwildfire.org

The official JWildfire forum
It is currently Thu May 06, 2021 1:12 am

All times are UTC+01:00




Post new topic Reply to topic  [3 posts ] 
Author Message
 Post subject: GUI glitches, bug?
PostPosted:Thu Jul 30, 2020 12:03 pm 
Offline

Joined:Sun Aug 04, 2013 12:52 pm
Posts:1
Since I built a new computer and installed JWildfire I have been having GUI glitches like the one in the screenshot below. I have spent many hours troubleshooting the problem, but since it sometimes happens 10 seconds or less after creating a new flame from scratch, or editing a randomized one, it's hard to point out exactly what causes this. Sometimes it takes minutes, and in a very few occasions up to an hour.

I have tried changing more or less every setting in JWF that I think could assist causing this issue. Tried different scaling (both font and UI), everything from 1024 MB memory to 16384 MB memory.

Yesterday I did notice one thing while I was working with a flame. There was one specific
event that caused the glitches everytime (otherwise they have seemed to be quite random). Clicking "Post Symmetry" and then "Symmetry Type". So I removed the properties files to reset all settings. I could suddenly click Symmetry Type without getting the glitches. So I started to make micro adjustments in settings again, and when I changed the theme from NIMBUS to AERO, the issue came back.

Thinking this was it, I kept the NIMBUS theme, and everything was working, for a couple of minutes, until I did something else, and it triggered again. How can different GUI's cause the same problem, but at different events?

I have tried v5.0.0, 5.5.0, 5.6.0 and the latest beta of 6.0.0, but all behave the same. I have tried different versions of JAVA as well, different video card drivers and so on. The reason for me thinking this is some kind of bug is because I don't have any other software on my computer behaving the same way. I have one other software using JAVA on my computer, VoxelShop, but I haven't been able to trigger this issue there.

My current rig:

ASUS ROG Maximus XII Hero
Intel Core i9-10900K
128 GB Corsair Vengeance Pro RGB DDR4 (3600 MHz)
2 x ASUS Strix GTX 780 6 GB (the only thing I have left from my old computer)
2 x Seagate FireCuda 520 2 TB M.2
1 x Corsair Force MP510 SSD 4 TB M.2 NVMe

I think I can rule out the video cards as the problem, since JWildfire was working perfectly in my old rig.

I have more than advertised above, but it would be so much to write exactly everything. Does anyone have any input (preferrably a solution of course :)), or ideas what I can test next?

Could there be some old code in JWildfire that don't like my current computer setup? Anyone having a similar setup?
Attachment:
2020-07-30.png


You do not have the required permissions to view the files attached to this post.


Top
   
 Post subject: Re: GUI glitches, bug?
PostPosted:Thu Jul 30, 2020 11:40 pm 
Offline
Site Admin
User avatar

Joined:Wed May 15, 2013 10:28 pm
Posts:1538
Because JWildfire is based on Java (and does not access low-level layers of your system directly) I think there might be a problem with the java runtime on your system.
In fact, it may be very important which java version do you use.
My suggestion is to use Oracle Java version 8 (not OpenJDK).
Did you try this?

I do not know VoxelShop, but from the Screenshot I saw, it seems to use another UI stack (SWT) than JWildfire (Swing). SWT uses native widgets, while Swing is more platform-independant, so it is very different.

Good luck!


Top
   
 Post subject: Re: GUI glitches, bug?
PostPosted:Thu Jul 30, 2020 11:58 pm 
Offline
Site Admin
User avatar

Joined:Wed May 15, 2013 10:28 pm
Posts:1538
And in case you missed it: you must select the java-version to use in the launcher, only installing another version will not change the version which is actually used.

Cheers!


Top
   
Display posts from previous: Sort by 
Post new topic Reply to topic  [3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Theme Created by HOLLYSMOKE
Theme updated to phpBB 3.1.6 by KamijouTouma
Theme Version is 3.1.6-ss2